Incidente en Correu
Incident Report for Estat dels serveis
Resolved
This incident has been resolved.
Posted Feb 18, 2024 - 12:34 CET
Update
Correu vuelve a estar operativo
Posted Feb 17, 2024 - 18:01 CET
Investigating
Correu no está operativo.
Posted Feb 17, 2024 - 17:50 CET
This incident affected: Correu.